Important Update: Changes to PPS Deposit Details
Incident Report for Brink POS
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2024 - 08:27 PST
Investigating
Dear Valued Customers,
We are pleased to inform you of an important update that we believe will enhance your experience with our services. Based on your valuable feedback, we have made a significant improvement to the way PPS deposits are processed.

What's Changing?
Previously, when submitting PPS deposits, only the legal entity name was included. Beginning Monday, November 25, 2024, we will be submitting the DBA (Doing Business As) name instead. This change will help you better identify your deposits, especially if you have multiple Merchant IDs (MIDs) depositing into the same bank account.

Key Benefits
• Enhanced Identification: With the DBA name being submitted, you will find it easier to recognize and categorize your deposits.
• Better Management: This improvement will be particularly beneficial for customers managing multiple MIDs, ensuring greater clarity and organization in your financial records.

Important Note
Please note that while we will be providing these details, it is ultimately up to the receiving bank to decide whether they include the DBA name in the deposit descriptor. However, by making this change, we ensure that these details are available for the bank to use.

We are committed to continuously improving our services based on your feedback. We believe this update will provide significant value and make your interactions with our system more seamless and efficient.

Should you have any questions or require further assistance, please do not hesitate to contact our customer support team.

Thank you for your continued trust and support.
Posted Nov 18, 2024 - 08:25 PST
This incident affects: PAR Payment Services.