Support Phone System Outage
Incident Report for Brink POS
Resolved
All phone services are currently back to normal operation. This incident has been resolved.
Posted Apr 22, 2024 - 11:25 PDT
Monitoring
Our phone service provider has migration measures in place and we are starting to see recovery of our phone services. We will continue to monitor until they are restored to full working condition.

In the meantime, please continue to utilize these support email addresses as needed support.brinksoftware@partech.com for direct support customers and BrinkPartnerSupport@partech.com for partner and peer-to-peer customers. We will provide another update within one hour.
Posted Apr 22, 2024 - 09:38 PDT
Investigating
We are currently experiencing an issue with our phone service preventing our support team from making inbound and outbound calls.

While we are working urgently with our phone service provider as this issue is being resolved, please utilize the support email paths of support.brinksoftware@partech.com for direct support customers and BrinkPartnerSupport@partech.com for partner and peer-to-peer customers.

We appreciate your patience and will provide an update each hour until this is resolved
Posted Apr 22, 2024 - 08:13 PDT
This incident affected: Customer Support Telephone Services.