PAR Pay Duplicate Settlement
Incident Report for Brink POS
Resolved
Dear PAR Pay Customer,

We have identified all files impacted on April 20th, 2024. We have started the process to reverse all impacted charges, please do not issue a refund as we will be automatically adjusting these transactions. All refunds and adjustments will be finalized by April 26, 2024 8:00 PM EST.

Thank you for your patience as we addressed this matter.

PAR Payment Services
Posted Apr 25, 2024 - 06:41 PDT
Identified
Dear PAR Pay Customer,

PAR Pay is aware of a small number of duplicate transactions from April 20th, 2024. While we investigate the root cause, we ask that you please do not refund customers. We anticipate this to be resolved within 24 - 48 hours and all customers will receive a refund. We will issue a new status update as soon as this has been completed.

We sincerely apologize for the disruption this may have caused to your business.
Posted Apr 24, 2024 - 15:50 PDT
This incident affected: PAR Payment Services.